- NetBSD Manual Pages
USCANNER(4) NetBSD Kernel Interfaces Manual USCANNER(4)
Powered by man-cgi (2020-09-24).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
uscanner -- minimal USB support for scanners
uscanner* at uhub?
The uscanner driver provides minimal support for USB scanners. The
driver recognizes a number of USB scanners, but to actually scan anything
there needs to be software that knows about the particular scanner. The
SANE package provides support for some scanners.
The uscanner driver works with the following scanners:
Perfection 1200U Photo
Many other scanners are recognized, but there is no software support for
scanimage(1), usb(4), usscanner(4)
USB Scanners under Linux, http://www.buzzard.org.uk/jonathan/scanners-
The uscanner driver appeared in NetBSD 1.6.
This driver should not really exist. The scanners it recognizes can be
accessed through the ugen(4) driver instead. A proper scanner driver
would provide a uniform interface to scanners instead of exposing the
innards of the scanner. The reason the driver exists is to have some-
thing that is compatible with the Linux driver.
NetBSD 9.99 September 10, 2000 NetBSD 9.99