- NetBSD Manual Pages
UMS(4) NetBSD Kernel Interfaces Manual UMS(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
ums -- USB mouse and touchpanel support
ums* at uhidev? reportid ?
wsmouse* at ums?
The ums driver provides support for USB mice and touchpanels. Access to
the movement data is through the wsmouse(4) driver.
Be aware that many USB mice will, if the mouse device is not open, detach
and reattach themselves repeatedly at regular intervals (usually around
one minute) causing spam on the console and the system log. This is
apparently intentional behavior on the part of the hardware manufactur-
ers. The best workaround is to keep the mouse device open, either via
X11, or, if not using the window system, by running wsmoused(8).
uhidev(4), usb(4), wsmouse(4)
The ums driver appeared in NetBSD 1.4. Touchpanel support was added in
NetBSD 10.99 June 6, 2021 NetBSD 10.99