- NetBSD Manual Pages
SERVICES(5) NetBSD File Formats Manual SERVICES(5)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
services -- service name data base
The services file contains information regarding the known services
available in the DARPA Internet. For each service a single line should
be present with the following information:
official service name
Items are separated by any number of blanks and/or tab characters. The
port number and protocol name are considered a single item; a slash (`/')
is used to separate the port and protocol (e.g. `512/tcp'). A hash (`#')
indicates the beginning of a comment; subsequent characters up to the end
of the line are not interpreted by the routines which search the file.
Service names may contain any printable character other than a field
delimiter, newline, or comment character.
The database in /var/db/services.cdb needs to be updated with
services_mkdb(8) after changes to the services file have been applied.
/etc/services The current services file.
/var/db/services.cdb The current services database.
The services file format appeared in 4.2BSD.
A name server should be used instead of a static file.
NetBSD 10.99 February 12, 2023 NetBSD 10.99