- NetBSD Manual Pages
PAM_ECHO(8) NetBSD System Manager's Manual PAM_ECHO(8)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
pam_echo -- Echo PAM module
[service-name] module-type control-flag pam_echo [arguments]
The echo service module for PAM displays its arguments to the user, sepa-
rated by spaces, using the current conversation function.
If the % character occurs anywhere in the arguments to pam_echo, it is
assumed to introduce one of the following escape sequences:
%H The name of the host on which the client runs (PAM_RHOST).
%s The current service name (PAM_SERVICE).
%t The name of the controlling tty (PAM_TTY).
%U The applicant's user name (PAM_RUSER).
%u The target account's user name (PAM_USER).
Any other two-character sequence beginning with % expands to the charac-
ter following the % character.
The pam_echo module and this manual page were developed for the FreeBSD
Project by ThinkSec AS and NAI Labs, the Security Research Division of
Network Associates, Inc. under DARPA/SPAWAR contract N66001-01-C-8035
(``CBOSS''), as part of the DARPA CHATS research program.
NetBSD 9.99 February 6, 2003 NetBSD 9.99