- NetBSD Manual Pages
MEM(4) NetBSD/sparc Kernel Interfaces Manual MEM(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
mem, kmem -- Sun main memory access driver
The file /dev/mem is an interface to the physical memory of the computer.
Byte offsets in this file are interpreted as physical memory addresses.
Reading and writing this file is equivalent to reading and writing memory
itself. An error will be returned if an attempt is made to reference an
offset outside of /dev/mem.
Kernel virtual memory is accessed via the file /dev/kmem in the same man-
ner as /dev/mem. Only kernel virtual addresses that are currently mapped
to memory are allowed.
On the SPARC, physical memory may be discontiguous; kernel virtual memory
begins at 0xf0000000.
The files mem and kmem appeared in Version 6 AT&T UNIX.
NetBSD 9.99 June 5, 1993 NetBSD 9.99