- NetBSD Manual Pages
SHT4XTEMP(4) NetBSD Kernel Interfaces Manual SHT4XTEMP(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
sht4xtemp -- Driver for Sensirion SHT40/SHT41/SHT45 sensor chip via I2C
sht4xtemp* at iic? addr 0x44
The sht4xtemp driver provides measurements from the SHT40/SHT41/SHT45
humidity/temperature sensors via the envsys(4) framework. The sht4xtemp
addr argument selects the address at the iic(4) bus. The resolution,
heater controls and crc validity can be changed through sysctl(8) nodes.
The following sysctl(3) variables are provided:
Lists the resolutions supported by the driver and chip.
Set the resolution, or number of bits, used for %RH and tempera-
ture. Use one of the strings listed in hw.sht4xtemp.resolutions.
If set, the crc calculation for %RH and temperature will be
Turn the heater on and off. Please note that the heater is
turned on right before the measurement and runs for a pulse width
of time. Then the measurement is taken and the heater is turned
off. There is no way to keep the heater running with this chip.
From 1 to 3, the amount of energy put into the heater. The
higher the number, the more power used.
Lists the valid heater pulses supported by the driver and chip.
Set the heater pulse length. Use one of the strings listed in
If the driver is compiled with SI70XX_DEBUG, this node will
appear and can be used to set the debugging level.
To read %RH or temperature the chip requires that the command be
sent, then a delay must be observed before a read can be done to
get the values back. The delays are documented in the datasheet
for the chip. The driver will attempt to read back the values
readattempts number of times. The default is 10 which should be
more than enough for most purposes.
envsys(4), iic(4), envstat(8), sysctl(8)
The sht4xtemp driver first appeared in NetBSD 10.0.
The sht4xtemp driver was written by Brad Spencer <firstname.lastname@example.org>.
NetBSD 10.99 September 28, 2021 NetBSD 10.99