- NetBSD Manual Pages
MAVB(4) NetBSD/sgimips Kernel Interfaces Manual MAVB(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
mavb -- Moosehead A/V Board audio device
mavb0 at mace0 offset 0x300000 intr 6
audio* at audiobus?
The mavb driver provides support for the Moosehead A/V Board found on SGI
The Moosehead A/V Board uses an AD1843 codec that supports 8- and 16-bit
audio sample recording and playback at rates from 5 to 54 kHz, with 1 Hz
resolution. The mavb driver also makes it possible to control the play-
back volume by using the buttons on the front of the O2.
audio(4), sgimips/intro(4), sgimips/mace(4)
The mavb driver first appeared in OpenBSD 3.7. It was later ported to
The mavb driver was written by Mark Kettenis, and ported to NetBSD by
Jared D. McNeill.
The analog mixer in the AD1843 codec does not provide a master volume
control. Therefore, the O2 volume buttons only control the output volume
of the DAC.
Currently only sample rates up to 48 kHz are supported. Recording is not
implemented yet. The second DAC on the AD1843 codec sits idle.
NetBSD 10.99 February 17, 2017 NetBSD 10.99