preempt(9) - NetBSD Manual Pages

Command: Section: Arch: Collection:  
PREEMPT(9)             NetBSD Kernel Developer's Manual             PREEMPT(9)


NAME
preempt, yield -- general preempt and yield functions
SYNOPSIS
#include <sys/sched.h> void preempt(void); #include <sys/proc.h> void yield(void);
DESCRIPTION
The preempt() function puts the current LWP back on the system run queue and performs an involuntary context switch. The yield() function is mostly same as preempt(), except that it performs a voluntary context switch. These functions drop the kernel lock before switching and re-acquire it before returning. NetBSD 10.99 July 3, 2007 NetBSD 10.99
Powered by man-cgi (2024-03-20). Maintained for NetBSD by Kimmo Suominen. Based on man-cgi by Panagiotis Christias.