- NetBSD Manual Pages
PIIXPCIB(4) NetBSD Kernel Interfaces Manual PIIXPCIB(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
piixpcib -- Intel PIIX4 PCI-ISA bridge with SpeedStep
piixpcib* at pci? dev ? function ?
isa* at piixpcib?
The piixpcib driver provides support for the Intel PIIX and compatible
PCI-ISA Bridges with Intel's first generation SpeedStep.
Frequency scaling is supported on Pentium III with two voltage modes,
used by SpeedStep as power states low and high. The driver will switch
into low power state by reducing voltage and frequency of the CPU. The
factor depends on the processor itself, but will always reduce power con-
sumption about 1/2.
The user can manually control the CPU frequency with the sysctl(8) pro-
gram using the following node:
machdep.speedstep_state = [0/1]
est(4), isa(4), pci(4), apmd(8), sysctl(8)
The piixpcib driver first appeared in FreeBSD 5.5 and then in NetBSD 4.0.
The current piixpcib driver was written by Bruno Ducrot. It was ported
to NetBSD by Jared D. McNeill <jmcneill@NetBSD.org>.
NetBSD 10.99 March 1, 2011 NetBSD 10.99