- NetBSD Manual Pages
USLSA(4) NetBSD Kernel Interfaces Manual USLSA(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
uslsa -- USB support for Silicon Labs CP210x series serial adapters
uslsa* at uhub?
ucom* at uslsa?
The uslsa driver is known to work with the following adapters:
Adafruit 954 USB to TTL Serial Cable
Helicomm IP-Link 1220-DVM
Nokia CA-42 USB
Siemens MC60 Data Cable
Suunto USB Serial Adaptor
The uslsa driver provides support for the Silicon Labs USB-to-RS-232
The device is accessed through the ucom(4) driver which makes it behave
like a tty(4).
tty(4), ucom(4), usb(4)
Silicon Laboratories: http://www.silabs.com.
Silicon Laboratories AN571: CP210x Virtual COM Port Interface..
The uslsa driver appeared in NetBSD 4.0.
The uslsa driver was written by Jonathan A. Kollasch. Code and style was
borrowed from existing NetBSD USB-serial drivers.
Settings other than 8 data bits, no parity, and 1 stop bit seem to be
refused by the CP2101.
NetBSD 10.99 January 27, 2019 NetBSD 10.99