- NetBSD Manual Pages
PAD(4) NetBSD Kernel Interfaces Manual PAD(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
pad -- Pseudo audio device driver
audio* at audiobus?
pad is a pseudo-device driver which provides support for feeding back PCM
data from consumers of an audio(4) device to userland.
The raw PCM data readable from /dev/padN is encoded in stereo little-
endian 16-bit linear PCM at 44100 Hz.
The pad pseudo-device driver receives data from /dev/audioN and feeds the
raw PCM output to /dev/padN. /dev/audioN is created once /dev/padN is
The following example streams an MP3 to an Apple AirTunes compatible
$ rtunes - < /dev/pad0 &
$ mpg123 -a /dev/audio1 mozart.mp3
Record the output of an application (in this case, audioplay):
$ ffmpeg -f s16le -ar 44100 -ac 2 -i /dev/pad0 output.wav
$ audioplay -d /dev/audio1 input.wav
The pad driver appeared in NetBSD 5.0.
Jared D. McNeill <firstname.lastname@example.org>
NetBSD 10.99 February 6, 2021 NetBSD 10.99