- NetBSD Manual Pages
EDQUOTA(8) NetBSD System Manager's Manual EDQUOTA(8)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
edquota -- edit user quotas
edquota [-Hu] [-f file-system] [-p proto-username] -d | username ...
edquota [-H] -g [-f file-system] [-p proto-groupname] -d | groupname ...
edquota [-Hu] [-f file-system] [-h block#/inode#] [-s block#/inode#]
[-t block grace time/inode grace time] -d | username ...
edquota [-H] -g [-f file-system] [-h block#/inode#] [-s block#/inode#]
[-t block grace time/inode grace time] -d | groupname ...
edquota [-Hu] -c [-f file-system] username ...
edquota [-H] -g -c [-f file-system] groupname ...
edquota is a quota editor. By default, or if the -u flag is specified,
one or more users may be specified on the command line. Unless -h, -s,
or -t are used, a temporary file is created for each user with an ASCII
representation of the current disk quotas and grace time for that user.
By default, quota for all quota-enabled file systems are edited; the -f
option can be used to restrict it to a single file system. An editor is
invoked on the ASCII file. The editor invoked is vi(1) unless the envi-
ronment variable EDITOR specifies otherwise.
The quotas may then be modified, new quotas added, etc. Setting a quota
to - or unlimited indicates that no quota should be imposed. Setting a
quota to zero indicates that no allocation is permited. Setting a soft
limit to zero with a unlimited hard limit indicates that allocations
should be permitted on only a temporary basis. The current usage infor-
mation in the file is for informational purposes; only the hard and soft
limits, and grace time can be changed.
Users are permitted to exceed their soft limits for a grace period that
may be specified per user (or per-file system for quota version 1). Once
the grace period has expired, the soft limit is enforced as a hard limit.
The default grace period is one week.
By default, disk quotas are in KB, grace time in seconds. Disk and
inodes quota can be entered with a humanize_number(9) suffix (K for kilo,
M for mega, G for giga, T for tera). Time can be entered with Y (year),
W (week), D (day), H (hour) and M (minute) suffixes. Suffixes can be
mixed (see EXAMPLES below). If the -H option if used, current quota,
disk usage and time are displayed in a human-readable format.
On leaving the editor, edquota reads the temporary file and modifies the
on-disk quotas to reflect the changes made.
If the -p flag is specified, edquota will duplicate the quotas of the
prototypical user specified for each user specified.
The -h, -s, and -t flags can be used to change quota limits (hard, soft
and grace time, respectively) without user interaction, for usage in e.g.
batch scripts. The arguments are the new block and inode number limit or
grace time, separated by a slash. Units suffix may be used, as in the
If the -g flag is specified, edquota is invoked to edit the quotas of one
or more groups specified on the command line.
With quota version 2, there is a per-file system user or group default
quota to be copied to a user or group quota on the first allocation. The
-d flag adds the default quota to the list of users or groups to edit.
For quota version 1, there is no default block/inode quota, and no per-
user/group grace time. To edit the file system-wide grace time, use -d.
On quota2-enabled file systems, the -c flag cause edquota to clear quota
entries for the specified users or groups. If disk or inode usages is
not 0, limits are reverted to the default quota. If disk and inode
usages are 0, the existing quota entries are freed.
Only the super-user may edit quotas.
Edit quotas for group games on all quota-enabled file systems:
Set 4MB hard block limit, 2MB soft block limit, 2048 inode hard limit,
1024 inode soft limit, 2 weeks and 3 days (or 17 days) block and inode
grace time for the default quotas on file system /home:
edquota -h 4M/2k -s 2M/1k -t 2W3D/2W3D -f /home -u -d
quota(1), humanize_number(3), libquota(3), fstab(5), quotacheck(8),
quotaon(8), quotarestore(8), repquota(8)
NetBSD 9.99 January 29, 2012 NetBSD 9.99