- NetBSD Manual Pages
KGMON(8) NetBSD System Manager's Manual KGMON(8)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
kgmon -- generate a dump of the operating system's profile buffers
kgmon [-bdhpr] [-c cpuid] [-M core] [-N system]
kgmon is a tool used when profiling the operating system. When no argu-
ments are supplied, kgmon indicates the state of operating system profil-
ing as running, off, or not configured (see config(1)). If the -p flag
is specified, kgmon extracts profile data from the operating system and
produces a gmon.out or gmon-<id>.out file suitable for later analysis by
The options are as follows:
-b Resume the collection of profile data.
Operate on the CPU specified by cpuid. If this option is speci-
fied with -p, the output file name will be gmon-<id>.out instead
of gmon.out. And if the cpuid argument is ``all'' , the opera-
tion is performed for each cpu.
-d Enable debug output.
-h Stop the collection of profile data.
Extract values associated with the name list from the specified
core instead of the default /dev/kmem.
Extract the name list from the specified system instead of the
-p Dump the contents of the profile buffers into a gmon.out or
-r Reset all the profile buffers. If the -p flag is also specified,
the gmon.out or gmon-<id>.out file is generated before the
buffers are reset.
If neither -b nor -h is specified, the state of profiling collection
remains unchanged. For example, if the -p flag is specified and profile
data is being collected, profiling will be momentarily suspended, the
operating system profile buffers will be dumped, and profiling will be
/netbsd the default system
/dev/kmem the default memory
Users with only read permission on /dev/kmem cannot change the state of
profiling collection. They can get a gmon.out file with the warning that
the data may be inconsistent if profiling is in progress.
The kgmon command appeared in 4.2BSD.
NetBSD 9.99 August 10, 2021 NetBSD 9.99