- NetBSD Manual Pages
ARP(4) NetBSD Kernel Interfaces Manual ARP(4)
Powered by man-cgi (2020-09-24).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
arp -- Address Resolution Protocol
The Address Resolution Protocol (ARP) is a protocol used to dynamically
map between Internet host addresses and Ethernet addresses. It is used
by all the Ethernet interface drivers. It is not specific to Internet
protocols or to Ethernet, but this implementation currently supports only
ARP caches Internet-Ethernet address mappings. When an interface
requests a mapping for an address not in the cache, ARP queues the mes-
sage which requires the mapping and broadcasts a message on the associ-
ated network requesting the address mapping. If a response is provided,
the new mapping is cached and any pending message is transmitted. ARP
will queue at most one packet while waiting for a response to a mapping
request; only the most recently ``transmitted'' packet is kept. If the
target host does not respond after several requests, the host is consid-
ered to be down for a short period (normally 20 seconds), allowing an
error to be returned to transmission attempts during this interval. The
error is EHOSTDOWN for a non-responding destination host, and
EHOSTUNREACH for a non-responding router.
Each ARP cache entry is stored in a network interface which a response of
ARP comes in. ARP cache entires time out periodically (normally 20 min-
utes after validated; entries are not validated when not in use).
ARP entries may be added, deleted or changed with the arp(8) utility.
Manually-added entries may be temporary or permanent, and may be
``published'', in which case the system will respond to ARP requests for
that host as if it were the target of the request.
In the past, ARP was used to negotiate the use of a trailer encapsula-
tion. This is no longer supported.
ARP implements Address Conflict Detection. When an address is first
added to the host, it is marked tentative and ARP probes the network to
discover if another host has the address. If another host replies with
the same address, then the local address is marked duplicate and the host
will not use it. Otherwise the tentative mark is removed and the host
can start using the address.
ARP will defend the host's active address when a conflicting message is
received. However, if another conflicting message for the address is
found within a 10 second period, then the address is marked duplicate and
the host will stop using it.
For some systems such as a router or a server, it is desirable never to
give up an assigned address. This can be achieved by setting the
sysctl(7) variable net.inet.ip_dad_count to 0.
In all of the above cases, ARP will log diagnostic messages which include
the hardware address of the conflicting host.
inet(4), route(4), arp(8), ifconfig(8), route(8)
Plummer, D., "RFC 826", An Ethernet Address Resolution Protocol.
Leffler, S.J. and Karels, M.J., "RFC 893", Trailer Encapsulations.
Cheshire, S., "RFC 5227", IPv4 Address Conflict Detection.
Since NetBSD 8.0, the ARP cache was not stored in the routing table.
Address Conflict Detection was added in NetBSD 8.0.
NetBSD 9.99 October 12, 2016 NetBSD 9.99