- NetBSD Manual Pages
VETHER(4) NetBSD Kernel Interfaces Manual VETHER(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
vether -- virtual Ethernet interface
The vether interface simulates a normal Ethernet interface by encapsulat-
ing standard network frames with an Ethernet header, specifically for use
as a member in a bridge(4).
To use vether the administrator needs to configure an address onto the
interface so that packets can be routed to it. An Ethernet header will
be prepended and, if the vether interface is a member of a bridge(4), the
frame will show up there.
The vether interface first appeared in OpenBSD 4.7 and NetBSD 10.
Theo de Raadt <email@example.com>
Like tap(4), the Ethernet address chosen will be partially random, and
may occasionally collide with another address.
NetBSD 10.99 October 17, 2017 NetBSD 10.99