- NetBSD Manual Pages
UMODEM(4) NetBSD Kernel Interfaces Manual UMODEM(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
umodem -- USB modem support
umodem* at uhub?
ucom* at umodem?
The umodem driver provides support for USB modems in the Communication
Device Class using the Abstract Control Model. These modems are basi-
cally standard serial line modems, but they are accessed via USB instead.
They support a regular AT command set. The commands can either be multi-
plexed with the data stream or handled through separate pipes. In the
latter case the AT commands have to be given on a device separate from
the data device.
The device is accessed through the ucom(4) driver which makes it behave
like a tty(4).
tty(4), ucom(4), usb(4)
The umodem driver appeared in NetBSD 1.5.
Only modems with multiplexed commands and data are supported at the
NetBSD 10.99 August 16, 1999 NetBSD 10.99