rwhod(8)
- NetBSD Manual Pages
RWHOD(8) NetBSD System Manager's Manual RWHOD(8)
NAME
rwhod -- system status server
SYNOPSIS
rwhod [-i interval] [-u user]
DESCRIPTION
rwhod is the server which maintains the database used by the rwho(1) and
ruptime(1) programs. Its operation is predicated on the ability to
broadcast messages on a network.
The following options are available:
-i interval Allows for the broadcast interval to be changed from the
default 3 minutes. The interval argument is the number of
seconds to change the interval to, or if the value is suf-
fixed by ``m'' then it is interpreted as minutes. The maxi-
mum allowed value for the broadcast interval is 11 minutes
because higher values will cause ruptime(1) to mark the host
as being down.
-u user Drop privileges and become the user user.
rwhod operates as both a producer and consumer of status information. As
a producer of information it periodically queries the state of the system
and constructs status messages which are broadcast on a network. As a
consumer of information, it listens for other rwhod servers' status mes-
sages, validating them, then recording them in a collection of files
located in the directory /var/rwho.
The server transmits and receives messages at the port indicated in the
``who'' service specification; see services(5). The messages sent and
received, are of the form:
struct outmp {
char out_line[8]; /* tty name */
char out_name[8]; /* user id */
int32_t out_time; /* time on */
};
struct whod {
char wd_vers;
char wd_type;
char wd_fill[2];
int32_t wd_sendtime;
int32_t wd_recvtime;
char wd_hostname[32];
int32_t wd_loadav[3];
int32_t wd_boottime;
struct whoent {
struct outmp we_utmp;
int32_t we_idle;
} wd_we[1024 / sizeof (struct whoent)];
};
All fields are converted to network byte order prior to transmission.
The load averages are as calculated by the w(1) program, and represent
load averages over the 5, 10, and 15 minute intervals prior to a server's
transmission; they are multiplied by 100 for representation in an inte-
ger. The host name included is that returned by the gethostname(3) func-
tion call, with any trailing domain name omitted. The array at the end
of the message contains information about the users logged in to the
sending machine. This information includes the contents of the utmp(5)
entry for each non-idle terminal line and a value indicating the time in
seconds since a character was last received on the terminal line.
Messages received by the rwho(1) server are discarded unless they origi-
nated at an rwho(1) server's port. In addition, if the host's name, as
specified in the message, contains any unprintable ASCII characters, the
message is discarded. Valid messages received by rwhod are placed in
files named whod.hostname in the directory /var/rwho. These files con-
tain only the most recent message, in the format described above.
Status messages are generated by default approximately once every 3 min-
utes.
SEE ALSO
ruptime(1), rwho(1)
HISTORY
The rwhod command appeared in 4.2BSD.
BUGS
There should be a way to relay status information between networks. Sta-
tus information should be sent only upon request rather than continu-
ously. People often interpret the server dying or network communication
failures as a machine going down.
NetBSD 10.99 September 12, 2005 NetBSD 10.99
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.