- NetBSD Manual Pages
PREEMPT(9) NetBSD Kernel Developer's Manual PREEMPT(9)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
preempt, yield -- general preempt and yield functions
The preempt() function puts the current LWP back on the system run queue
and performs an involuntary context switch. The yield() function is
mostly same as preempt(), except that it performs a voluntary context
These functions drop the kernel lock before switching and re-acquire it
NetBSD 9.99 July 3, 2007 NetBSD 9.99