- NetBSD Manual Pages
IXG(4) NetBSD Kernel Interfaces Manual IXG(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
ixg -- Intel(R) 10Gb Ethernet driver
ixg* at pci? dev ? function ?
The ixg driver provides support for PCI 10Gb Ethernet adapters based on
the Intel(R) 82598EB, 82599, X540 and X550 Ethernet Controllers. The
driver supports Jumbo Frames, TCP Segmentation Offload (TSO).
For questions related to hardware requirements, refer to the documenta-
tion supplied with your Intel 10GbE adapter. All hardware requirements
listed apply to use with NetBSD.
Support for Jumbo Frames is provided via the interface MTU setting.
Selecting an MTU larger than 1500 bytes with the ifconfig(8) utility con-
figures the adapter to receive and transmit Jumbo Frames. On NetBSD, the
maximum MTU size for Jumbo Frames is 9000 bytes.
This driver version supports VLANs. For information on enabling VLANs,
ixg%d: Unable to allocate bus resource: memory A fatal initialization
error has occurred.
ixg%d: Unable to allocate bus resource: interrupt A fatal initialization
error has occurred.
ixg%d: watchdog timeout -- resetting The device has stopped responding
to the network, or there is a problem with the network connection
For general information and support, go to the Intel support website at:
The ixg driver doesn't use the common MCLGET(9) interface and use the
driver specific cluster allocation mechanism. If it's exhausted, the
evcnt(9) counter "ixgX qY Rx no jumbo mbuf" is incremented. If this is
observed, the number can be changed by the following config parameter:
IXGBE_JCLNUM_MULTI The number of RX jumbo buffers (clusters) per
queue is calculated by IXGBE_JCLNUM_MULTI * (num-
ber of rx descriptors). The total number of clus-
ters per queue is available via the
arp(4), ixv(4), netintro(4), vlan(4), ifconfig(8)
The ixg device driver comes from FreeBSD, where it is called ixgbe. It
first appeared in NetBSD 6.0.
The ixg driver was written by Intel Corporation
<firstname.lastname@example.org>. It was imported from FreeBSD into NetBSD
David Young <dyoung@NetBSD.org>.
The hardware supports a maximum MTU of 16114 bytes, but the NetBSD port
of the driver supports only 9000 bytes.
NetBSD 9.99 March 9, 2021 NetBSD 9.99