- NetBSD Manual Pages
HARMONY(4) NetBSD/hppa Kernel Interfaces Manual HARMONY(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
harmony -- CS4215/AD1849 audio interface
harmony* at gsc?
audio* at harmony?
The harmony device uses the Crystal Semiconductor CS4215 16-Bit Multime-
dia Audio Codec or Analog Devices AD1849 SoundPort(R) Stereo Codec chip
to implement the audio device interface described in audio(4). This
device is found on most HP PA-RISC workstations. The harmony has a maxi-
mum precision of 16 bits with a maximum 48000 Hz sample rate, and has
stereo input and stereo output.
On HP 9000/712 models harmony also provides two additional channels for
an add-on card with two fax/voice modems.
One of the hardware registers reflects the state of the CHI bus that is
used to communicate with the codec and thus being sampled at a low accu-
racy secondary frequency (such as timeout(9)) produces a poor quality
random bit stream that is fed into the entropy pool of rnd(4).
An incomplete list of machines that feature harmony audio:
· B132L[+], B160L, B180L+
· C100, C110, C132L, C160[L], C180, C200, C240, C360
· J200, J210[XC], J280, J282, J2240
hppa/ioctl(2), audio(4), hppa/gsc(4), hppa/intro(4), rnd(4)
Support for harmony first appeared in OpenBSD 3.3. It was ported to
NetBSD 1.6 by Chuck Silvers.
To trigger entropy collection, the CHI bus has to be programmed into the
data mode that happens once a single buffer of data has been played or
NetBSD 9.99 May 15, 2022 NetBSD 9.99