- NetBSD Manual Pages
CPU_COREDUMP(9) NetBSD Kernel Developer's Manual CPU_COREDUMP(9)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
cpu_coredump -- machine-dependent process core dump interface
cpu_coredump(struct lwp *l, void *iocookie, struct core *chdr);
cpu_coredump32(struct lwp *l, void *iocookie, struct core32 *chdr);
cpu_coredump() is the machine-dependent interface invoked by machine-
independent code to dump the machine-dependent header information at the
start of a process core dump. The header information primarily consists
of the CPU and floating-point registers. l is the lwp structure of the
thread being dumped. iocookie is an opaque pointer to be passed to
coredump_write(). Information about the machine-dependent header sec-
tions are returned in chdr.
cpu_coredump() returns 0 on success and an appropriate error code on
Process core dumps are initiated within the file sys/kern/kern_sig.c.
Process core dumps for ELF NetBSD binaries are performed within the files
sys/kern/core_elf32.c or sys/kern/core_elf64.c. Process core dumps for
other NetBSD binaries are performed within the file
NetBSD 9.99 December 24, 2005 NetBSD 9.99