- NetBSD Manual Pages
FSCK_UDF(8) NetBSD System Manager's Manual FSCK_UDF(8)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
fsck_udf -- Universal Disk Format file system consistency checker
fsck_udf -p [-fH] file system ...
fsck_udf [-fHnSsy] file system ...
The fsck_udf utility verifies and repairs Universal Disk Format file sys-
tems (more commonly known as UDF file systems).
The first form of fsck_udf preens the specified file systems. It is nor-
mally started by fsck(8) run from /etc/rc during automatic reboot, when
an UDF file system is detected. When preening file systems, fsck_udf
will fix common inconsistencies non-interactively. If more serious prob-
lems are found, fsck_udf does not try to fix them, indicates that it was
not successful, and exits.
The second form of fsck_udf checks the specified file systems and tries
to repair all detected inconsistencies, requesting confirmation before
making any changes.
The options are as follows:
-f Force detailed checking even when file system is marked
-H Enables heuristic repair options repairing known corruptions
in the wild caused by bugs.
-n Causes fsck_udf to assume no as the answer to all operator
-p Preen the specified file systems.
-S Causes fsck_udf to scan for older VAT tables on recordable
media. This allows older snapshots of the file system on
recordable media to be recovered.
-s session Select session session to be checked on recordable media.
This allows older sessions of the file system on recordable
media to be recovered.
-y Causes fsck_udf to assume yes as the answer to all operator
fsck(8), fsck_ffs(8), mount_udf(8)
A fsck_udf utility appeared in NetBSD 10.0.
fsck_udf is still under construction. Not all possible reparations are
NetBSD 10.99 February 6, 2022 NetBSD 10.99