- NetBSD Manual Pages
VIOMB(4) NetBSD Kernel Interfaces Manual VIOMB(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
viomb -- VirtIO memory ballooning driver
virtio* at pci? dev ? function ?
viomb* at virtio?
virtio(4) defines an interface for efficient, standard, and extensible
I/O between the hypervisor and the virtual machine. The viomb driver
supports the virtio-compliant memory ballooning device.
Memory ballooning works as follows:
1. The host operator requests a guest to return some amount of memory
to the host (via e.g. Qemu monitor balloon command).
2. The hypervisor sends the request via VirtIO memory ballooning
3. The guest viomb driver requests allocation of that amount of physi-
cal memory from the NetBSD memory management system.
4. The viomb device tells the hypervisor the guest physical memory
address of the allocated memory via VirtIO memory ballooning device.
The sysctl node hw.viomb.npages shows the requested number of memory
pages to return to the hypervisor, while hw.viomb.actual shows the actual
number of memory pages that are already returned to the hypervisor.
virtio(4), sysctl(8), x86/balloon(4)
Rusty Russell, IBM Corporation, Virtio PCI Card Specification,
The viomb device driver appeared in NetBSD 6.0.
The userland interface should be same as the Xen ballooning device.
NetBSD 10.99 August 25, 2020 NetBSD 10.99