- NetBSD Manual Pages
SCMDSPI(4) NetBSD Kernel Interfaces Manual SCMDSPI(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
scmdspi -- SPI frontend to the Sparkfun Serial Controlled Motor Driver
scmd* at spi? slave 0
scmd* at spi? slave 1
The scmdspi driver provides the SPI frontend attachment for the Sparkfun
The following sysctl(3) variables are inherited from scmd(4) :
If the driver is compiled with SCMD_DEBUG, this node will appear
and can be used to set the debugging level.
/dev/scmdu character device allowing access to the register space of
a main u, SCMD device
iic(4), spi(4), scmdi2c(4), scmdspi(4), scmdctl(1), sysctl(8)
The scmdspi driver first appeared in NetBSD 10.0.
The scmdspi driver was written by Brad Spencer <email@example.com>.
When used in SPI mode, the SCMD device uses an odd method of doing reads
that can become stuck. See the command spi_read_one in the scmdctl(1)
utility to try and unstick the device when this happens.
NetBSD 10.99 December 1, 2021 NetBSD 10.99