- NetBSD Manual Pages
PROTOCOLS(5) NetBSD File Formats Manual PROTOCOLS(5)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
protocols -- protocol name data base
The protocols file contains information regarding the assigned protocol
numbers used by IPv4 and IPv6 to identify the next level protocol. For
each protocol a single line should be present with the following informa-
official protocol name
Items are separated by any number of blanks and/or tab characters. A
hash (``#'') indicates the beginning of a comment; characters up to the
end of the line are not interpreted by routines which search the file.
Protocol names may contain any printable character other than a field
delimiter, newline, or comment character.
/etc/protocols The protocols file resides in /etc.
IANA Allocation Guidelines For Values In the Internet Protocol and
Related Headers, RFC 2780, March 2000.
IANA Allocation Guidelines for the Protocol Field, RFC 5237, February
The protocols file format appeared in 4.2BSD, describing the "known pro-
tocols used in the DARPA Internet".
A name server should be used instead of a static file.
NetBSD 10.99 November 27, 2022 NetBSD 10.99