- NetBSD Manual Pages
NVMM(4) NetBSD Kernel Interfaces Manual NVMM(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
nvmm -- NetBSD Virtual Machine Monitor
The nvmm driver provides kernel support for hardware-accelerated virtual-
ization. It is made of a generic MI frontend, to which MD backends can
be plugged to implement the core virtualization.
In practice, nvmm is used by the libnvmm(3) API to implement hypervisors.
The following backends are supported:
- x86-SVM, for x86 AMD CPUs
- x86-VMX, for x86 Intel CPUs
Note that for VMX support, the CPU must also support "VMX Unrestricted
Guest", which is only present if Extended Page Tables (EPT) is supported.
The earliest CPU family with this feature is Westmere, and not all later
CPUs have it.
The nvmm driver was written by Maxime Villard.
NetBSD 10.99 July 30, 2023 NetBSD 10.99