- NetBSD Manual Pages
M25P(4) NetBSD Kernel Interfaces Manual M25P(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
m25p -- STMicroelectronics M25P family of SPI-connected flash devices
m25p* at spi0 slave 0
The m25p driver provides support for STMicrolelectronics' M25P family of
SPI connected NOR flash devices.
The machine-independent m25p driver was written by Garrett D'Amore for
the Champaign-Urbana Community Wireless Network Project (CUWiN), and
appeared in NetBSD 4.0.
Some important bits that are vital for use as a mass storage device are
still missing. Specifically, there is no API to erase the device, and
there is no support for device partitioning.
NetBSD 10.99 October 9, 2006 NetBSD 10.99