- NetBSD Manual Pages
CPU_CONFIGURE(9) NetBSD Kernel Developer's Manual CPU_CONFIGURE(9)
Powered by man-cgi (2021-03-02).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
cpu_configure -- machine-dependent device autoconfiguration
The machine-dependent cpu_configure() is called during system bootstrap
to perform the machine-dependent portion of device autoconfiguration. It
sets the configuration machinery in motion by finding the root bus
(``mainbus''). When this function returns, interrupts must be enabled.
The following tasks are performed by cpu_configure():
· initialize soft interrupts (see softint(9));
· initialize CPU interrupts and SPLs (see spl(9));
· call config_rootfound() for ``mainbus''; and
· complete any initialization deferred from cpu_startup(9).
NetBSD 9.99 April 13, 2010 NetBSD 9.99