- NetBSD Manual Pages
BATTERY_PMU(4) NetBSD Kernel Interfaces Manual BATTERY_PMU(4)
Powered by man-cgi 1.15, Panagiotis Christias
battery_pmu -- support for batteries and sensors in PCI-based Apple
battery* at pmu?
The battery_pmu driver provides support for batteries and hardware sen-
sors found in first generation PCI-based PowerBooks (i.e. Apple Powerbook
2400, 3400 and 3500 (also known as Original PowerBook G3). Currently it
only exports a few sensors via the envsys(4) interface, including battery
charge, voltage, CPU and battery temperature and AC power availability.
envsys(4), pmu(4), envstat(8)
There is no APM emulation right now and the battery current sensor may
return misleading or wrong data. This driver is considered preliminary
and may be replaced at some point.
NetBSD 9.99 May 18, 2009 NetBSD 9.99
Modified for NetBSD
by Kimmo Suominen