- NetBSD Manual Pages
AHT20TEMP(4) NetBSD Kernel Interfaces Manual AHT20TEMP(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
aht20temp -- Driver for Guangzhou Aosong AHT20 sensor chip via I2C bus
aht20temp* at iic? addr 0x38
The aht20temp driver provides measurements from the AHT20 humidity/tem-
perature sensors via the envsys(4) framework. The aht20temp addr argu-
ment selects the address at the iic(4) bus. The crc validity can be
changed through sysctl(8) nodes.
The following sysctl(3) variables are provided:
If set, the crc calculation for %RH and temperature will be
If the driver is compiled with AHT20_DEBUG, this node will appear
and can be used to set the debugging level.
To read %RH or temperature the chip requires that the command be
sent, then a delay must be observed before a read can be done to
get the values back. The delays are documented in the datasheet
for the chip. The driver will attempt to read back the values
readattempts number of times. The default is 10 which should be
more than enough for most purposes.
envsys(4), iic(4), envstat(8), sysctl(8)
The aht20temp driver first appeared in NetBSD 10.0.
The aht20temp driver was written by Brad Spencer <firstname.lastname@example.org>.
NetBSD 10.99 November 15, 2022 NetBSD 10.99