- NetBSD Manual Pages
ACCF_DATA(9) NetBSD Kernel Developer's Manual ACCF_DATA(9)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
accf_data -- buffer incoming connections until data arrives
This is a filter to be placed on a socket that will be using accept() to
receive incoming connections.
It prevents the application from receiving the connected descriptor via
accept() until data arrives on the connection.
If the accf_data accept filter is present in the kernel configuration,
this will enable the data accept filter on the socket sok.
struct accept_filter_arg afa;
setsockopt(sok, SOL_SOCKET, SO_ACCEPTFILTER, &afa, sizeof(afa));
setsockopt(2), accept_filter(9), accf_http(9)
The accept filter mechanism and the accf_data filter were introduced in
FreeBSD 4.0. They were ported to NetBSD by Coyote Point Systems and
appeared in NetBSD 5.0.
This manual page and the filter were written by Alfred Perlstein.
NetBSD 9.99 August 10, 2008 NetBSD 9.99