- NetBSD Manual Pages
MOUNT_9P(8) NetBSD System Manager's Manual MOUNT_9P(8)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
mount_9p -- mount a file server using the 9P resource sharing protocol
mount_9p [-su] [-o mntopts] [-p port] [user@]host[:path] mount_point
The mount_9p program is used to mount a file hierarchy served with the
Plan 9 file sharing protocol: 9P. After the file system is mounted, the
files on the remote host will be accessed using the credentials of the
user named user and whatever UID the user happens to have on the remote
server. If path is supplied, it is used as the mount rootpath on the
remote host. path must be an absolute path.
By default mount_9p runs in the background with daemon(3). With the -s
option mount_9p runs in the forground.
By default mount_9p follows the 9P2000 protocol. With the -u option
mount_9p follows the 9P2000.u protocol that includes extensions to better
support Unix environments.
puffs(3), puffs(4), mount(8)
RFC and standards documents relating the 9P protocol,
The mount_9p utility first appeared in NetBSD 5.0.
Experimental 9P2000.u support appeared in NetBSD 9.0.
Permissions are not handled well.
Authentication support is missing.
Error code handling is missing for 9P2000.
9P2000.u support doesn't use extension fields.
NetBSD 9.3 June 7, 2019 NetBSD 9.3