- NetBSD Manual Pages
VIRTIO(4) NetBSD Kernel Interfaces Manual VIRTIO(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
virtio -- Para-virtualized I/O in a virtual machine
virtio* at fdt?
virtio* at pci? dev ? function ?
ld* at virtio?
vioif* at virtio?
viomb* at virtio?
viornd* at virtio?
vioscsi* at virtio?
virtio defines an interface for efficient, standard and extensible I/O
between the hypervisor and the virtual machine. The virtio device driver
represents an emulated device that the hypervisor makes available to the
virtio driver itself provides the core infrastructure to communicate with
the hypervisor (called virtqueues) and supports the following devices:
ld(4) A Disk device.
An Ethernet device.
A pseudo-device to release memory back to the hypervisor.
An entropy source.
A SCSI adapter.
ld(4), pci(4), vioif(4), viomb(4), viornd(4), vioscsi(4)
Rusty Russell, IBM Corporation, Virtio PCI Card Specification,
The virtio driver first appeared in NetBSD 6.0.
NetBSD 9.3 June 7, 2018 NetBSD 9.3