- NetBSD Manual Pages
FSIRAND(8) NetBSD System Manager's Manual FSIRAND(8)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
fsirand -- install random inode generation numbers in a filesystem
fsirand [-F] [-p] [-x constant] special
fsirand writes random inode generation numbers for all the inodes on
device special. These random numbers make the NFS filehandles less pre-
dictable, increasing security of exported filesystems.
fsirand should be run on a clean and unmounted filesystem.
The options are as follows:
-F Indicates that special is a file system image, rather than a
device name. special will be accessed `as-is', without requiring
that it is a raw character device and without attempting to read
-p Print the current inode generation numbers; the filesystem is not
Exclusive-or the given constant with the random number used in
the generation process.
fsirand exits zero on success, non-zero on failure.
If fsirand receives a SIGINFO signal, statistics on the amount of work
completed and estimated completion time (in minutes:seconds) will be
written to the standard error output.
A fsirand utility appeared in NetBSD 1.3.
Christos Zoulas <christos@NetBSD.org>.
NetBSD 9.3 September 11, 2016 NetBSD 9.3