- NetBSD Manual Pages
DTVIIC(4) NetBSD Kernel Interfaces Manual DTVIIC(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
dtviic, au8522, cx24227, lg3303, mt2131, nxt2k, zl10353, tvpll, xc3028,
xc5k -- Inter IC (I2C) modules for DTV
The dtviic modules provide support for dtv(4) devices. The dtviic module
group includes tuners, demodulators, and analog video decoders.
The usual hardware structure consists of a host controller (connected for
instance via usb(4) or pci(4)) that provides the data moving facilities
(for the analog or digital video streams) and an iic(4) bus over which
the other chips can be configured.
For example, a typical dtv(4) setup would look like this:
1. Initialize transport stream (TS) port on the host controller.
2. Configure the demodulator that ``demodulates'' the information
from an intermediate frequency (IF) that is provided to it by
the associated tuner. This step typically includes setting
the desired quadrature amplitude modulation (QAM) and band-
width, among other things.
3. Configure the tuner. Typically this step includes at least
setting the frequency.
4. Start TS transfer (using DMA transfers or USB high speed
The supported demodulators include:
au8522 Auvitek AU8522 ATSC/QAM64/QAM256 demodulator
cx24227 Conexant CX24227 ATSC/QAM64/QAM256 demodulator
lg3303 LG LGDT3303 ATSC/QAM64/QAM256 demodulator
mt2131 MicroTune MT2131 ATSC demodulator
nxt2k NxtWave Communications NXT2004 ATSC demodulator
zl10353 Zarlink ZL10353 (Intel CE623x) COFDM/DVB-T demodulator
The supported tuners are:
tvpll Generic PLL-based tuners
xc3028 XCeive XC3028 analog and digital tuner
xc5k Xceive XC5000 analog and digital tuner
· dvb-fe-nxt2004.fw needed by nxt2k
· xc3028-v27.fw or xc3028L-v36.fw (provided by
pkgsrc/sysutils/xc3028l-firmware) needed by xc3028
· dvb-fe-xc5000-1.6.114.fw needed by xc5k, provided by the
dtv(4), iic(4), module(7)
The dtviic modules first appeared in NetBSD 6.0.
Authors include Jared D. McNeill <jmcneill@NetBSD.org>, Jonathan A.
Kollasch <jakllsch@NetBSD.org>, and Jukka Ruohonen <firstname.lastname@example.org>.
NetBSD 9.3 August 30, 2011 NetBSD 9.3