- NetBSD Manual Pages
CORETEMP(4) NetBSD Kernel Interfaces Manual CORETEMP(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
coretemp -- Intel Core on-die digital thermal sensor
coretemp* at cpu?
The coretemp driver provides support for the on-die digital thermal sen-
sor present on Intel Core and newer CPUs.
The temperatures can be observed by using the envsys(4) API or the
envstat(8) command. Temperatures are reported for each core separately.
The coretemp driver is able to send a critical event to the powerd(8)
daemon. The script /etc/powerd/scripts/sensor_temperature will be exe-
cuted by the daemon (if running) when the limit has been reached.
envsys(4), envstat(8), powerd(8)
Michael Berktold and Tian Tian (Intel Corporation), CPU Monitoring With
DTS/PECI, White Paper, http://edc.intel.com/Download.aspx?id=2612,
The coretemp driver first appeared in FreeBSD 7.0. It was later ported
to NetBSD 5.0.
The coretemp driver was written by Rui Paulo <rpaulo@FreeBSD.org> as part
of a Google Summer of Code project. It was adapted to NetBSD by Juan
NetBSD 9.3 February 23, 2010 NetBSD 9.3