- NetBSD Manual Pages
CONS(4) NetBSD/i386 Kernel Interfaces Manual CONS(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
console -- i386 console interface
The ``console'' device is used for kernel printf messages and accesses to
the /dev/console character special device in user mode. It is attached
to a hardware interface at boot time controlled by options in the kernel
configuration file, or information passed by the boot loader.
Bootblocks from NetBSD 1.4 or newer select their console device from a
compiled-in list, and then pass their choice of console device and con-
sole parameters to the kernel.
As of NetBSD 1.5, the consdev bootblock command allows changing the con-
sole device on-the-fly.
The kernel will use the same console device as the bootblock; no special
kernel configuration is required.
To override the bootblock's choice of console, or to use a serial kernel
console with older bootblocks, you must specify kernel config-file
options to override the information passed by the bootblock. The current
option choices are:
- the standard PC keyboard and display
(with either the ``pc'' or the wscons(4) driver)
- standard PC serial ports
(with com(4) driver)
The available kernel configuration options are:
specifies the name of the console device. Valid values are ``pc'' for
the pc keyboard / display (default) and ``com'' for a serial port.
sets the base address for the serial console port (default: 0x3f8).
sets the baudrate for the serial console (default: 9600).
causes console information passed by the bootloader to be ignored and the
settings specified by the three options above (or the defaults) to be
used. Default behaviour is to use the settings from the bootloader if
present, and to use option / default values only if no information was
allows to specify terminal control flags. The argument is a ``cflag''
value, see termios(4) for details. Default is (CREAD | CS8 | HUPCL)
(8N1). This option takes always effect, because mode settings are not
passed by the bootloader.
config(1), tty(4), boot(8), boot_console(8)
The console device is chosen early in system startup regardless if the
specified driver / device is present in the system configuration file.
If the driver asked for by the bootloader or ``options CONSDEVNAME'' is
not configured into the system, a panic is caused. Because there is no
console device, no explaining message will be printed. If the driver is
present, but the specific device instance not, kernel printf will work,
but /dev/console becomes a dummy.
NetBSD 9.3 September 6, 2006 NetBSD 9.3