- NetBSD Manual Pages
DZ(4) NetBSD Kernel Interfaces Manual DZ(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
dz -- eMIPS console serial device interface
dz* at ebus0 addr ?
This serial line provides a simple communication line with no modem con-
trol. It is not adequate for UNIX dialup use.
Normal I/O control parameters for individual lines are managed by
ioctl(2) calls. Line speeds may be initiated via the ttys(5) file,
stty(1) or ifconfig(8) to name a few, see tty(4).
The dz driver monitors the rate of input on each board, and switches
between the use of character-at-a-time interrupts and input silos. While
the silo is enabled during periods of high-speed input, the driver polls
for input 30 times per second.
/dev/ttyD0 phys interface.
dz%d: silo overflow . The 1 character input silo overflowed before it
could be serviced. This can happen if a hard error occurs when the CPU
is running with elevated priority, as the system will then print a mes-
sage on the console with interrupts disabled. It is not serious.
stty(1), tty(4), ttys(5), getty(8)
A dz driver appeared in NetBSD 6.0.
NetBSD 9.3 July 17, 2010 NetBSD 9.3