- NetBSD Manual Pages
CISS(4) NetBSD Kernel Interfaces Manual CISS(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
ciss -- HP/Compaq Smart ARRAY 5/6 RAID controllers
ciss* at pci? function ?
The ciss driver provides support for the CISS interface implemented by
fifth and later generations of the HP/Compaq Smart ARRAY family of con-
The CISS interface is defined in the document entitled CISS Command
Interface for SCSI-3 Support Open Specification, Version 1.04, Valence
Number 1, Compaq Computer Corporation, 2000/11/27.
This driver supports several Compaq and HP controllers implementing the
CISS interface, including:
· Compaq Smart Array 5300 version 1
· Compaq Smart Array 5300 version 2
· Compaq Smart Array 5i version 1
· Compaq Smart Array 5i version 2
· HP Smart Array 5312
· HP Smart Array 6i
· HP Smart Array 641
· HP Smart Array 642
· HP Smart Array 6400
· HP Smart Array 6400 EM
· HP Smart Array E200
· HP Smart Array E200i
· HP Smart Array P400
· HP Smart Array P400i
· HP Smart Array P410i
· HP Smart Array P600
· HP Smart Array P800
· HP Smart Array V100
· HP Smart Array 1 through 13
These controllers support RAID 0, RAID 1, RAID 5, JBOD, and superposi-
tions of those configurations.
Although the controllers are actual RAID controllers, the ciss driver
makes them look just like SCSI controllers. All RAID configuration must
be done through the controllers' BIOSes.
Hardware from previous generations of this product family may be sup-
ported by the cac(4) driver.
bio(4), cac(4), intro(4), pci(4), scsi(4), sd(4)
The ciss driver first appeared in NetBSD 3.1.
The ciss driver was written by Michael Shalayeff <email@example.com>,
and ported to NetBSD by Tonnerre Lombard <firstname.lastname@example.org>.
NetBSD 9.3 October 18, 2016 NetBSD 9.3