- NetBSD Manual Pages
SHELLS(5) NetBSD File Formats Manual SHELLS(5)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
shells -- shell database
The shells file contains a list of the shells on the system. It can be
used in conjunction with the Hesiod domain `shells', and the NIS map
`shells', as controlled by nsswitch.conf(5).
For each shell a single line should be present, consisting of the shell's
path, relative to root.
A hash (``#'') indicates the beginning of a comment; subsequent charac-
ters up to the end of the line are not interpreted by the routines which
search the file. Blank lines are also ignored.
/etc/shells The shells file resides in /etc.
chsh(1), getusershell(3), nsswitch.conf(5)
The shells file format appeared in 4.3BSD-Tahoe.
The Hesiod and NIS support first appeared in NetBSD 1.4.
NetBSD 9.2 January 16, 1999 NetBSD 9.2