- NetBSD Manual Pages
RTFPS(4) NetBSD Kernel Interfaces Manual RTFPS(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
rtfps -- multiplexing serial communications interface
rtfps0 at isa? port 0x1230 irq 10
com2 at rtfps0 slave 0
com3 at rtfps0 slave 1
com4 at rtfps0 slave 2
com5 at rtfps0 slave 3
The rtfps driver provides support for IBM RT PC boards that multiplex
together up to four EIA RS-232C (CCITT V.28) or RS-422A communications
Each rtfps device is the master device for up to four com devices. The
kernel configuration specifies these com devices as slave devices of the
rtfps device, as shown in the synopsis. The port specification for the
rtfps device is used to compute the base addresses for the com subde-
The rtfps driver was written by Charles Hannum, based on the ast driver.
The rtfps driver is unlikely to work on non-EISA and non-PCI machines.
The ISA bus only asserts 10 I/O address lines, and this is not enough.
Even on EISA and PCI machines, some address conflicts have been observed.
On one machine, the second port always conflicted with something (though
it's not clear what) and caused strange results. Disabling the second
port in the kernel config allowed the other three ports to function cor-
NetBSD 9.2 August 7, 1994 NetBSD 9.2