- NetBSD Manual Pages
PNPBIOS(4) NetBSD/i386 Kernel Interfaces Manual PNPBIOS(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
pnpbios -- introduction to PnP BIOS support
pnpbios0 at mainbus?
XX* at pnpbios0 index ?
pnpbios provides support for finding and attaching devices by extracting
information from the PnP BIOS of a machine.
NetBSD includes the following pnpbios drivers, sorted by driver name:
com serial communications interface
ess ESS Technology AudioDrive family audio device driver
fdc floppy controller
joy game controller
lpt parallel port driver
pciide PCI IDE controllers driver
pckbc PC keyboard/mouse controller
sb SoundBlaster family audio device driver
wss Windows Sound System hardware driver
ym Yamaha OPL3-SA3 sound driver
com(4), ess(4), fdc(4), i386/intro(4), isa(4), joy(4), lpt(4), pci(4),
pciide(4), pckbc(4), sb(4), wss(4), ym(4)
The pnpbios driver appeared in NetBSD 1.5.
The pnpbios bus provides a different way to attach devices than the real
buses (e.g., isa(4)). The reason to use pnpbios instead of the real bus
is that some machines have weird routings of, e.g., interrupts. The
exact information about these things can be found in the BIOS, which is
why the pnpbios bus has a better chance of succeeding with getting it
Many older BIOS implementations do not support PnP, and some newer ones
do not follow the standards.
NetBSD 9.2 February 17, 2017 NetBSD 9.2