- NetBSD Manual Pages
MLD6QUERY(8) NetBSD System Manager's Manual MLD6QUERY(8)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
mld6query -- send multicast listener query
mld6query [-dr] intface [maddr]
mld6query sends an IPv6 multicast listener discovery (MLD) query packet
toward the specified multicast address, maddr, toward interface intface.
If you omit maddr, linklocal all nodes multicast address(ff02::1) is
After sending a query, mld6query waits for replies for at most 10 sec-
onds. If a reply is returned, mld6query prints it with its type and then
waits for another reply.
This program is provided only for debugging. It is not necessary for
With -d, mld6query will transmit MLD done packet instead of MLD query
packet. With -r, similarly, MLD report packet will be transmitted. -dr
options are for debugging purposes only.
The mld6query utility exits 0 on success, and >0 if an error occurs.
The mld6query command first appeared in WIDE/KAME IPv6 protocol stack
mld6query does not take care of multicast addresses which have non link-
NetBSD 9.2 May 17, 1998 NetBSD 9.2