- NetBSD Manual Pages
EHCI(4) NetBSD Kernel Interfaces Manual EHCI(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
ehci -- USB Enhanced Host Controller driver
ehci* at cardbus? function ?
ehci* at pci? dev ? function ?
usb* at ehci?
The ehci driver provides support for the USB Enhanced Host Controller
Interface, which is used by USB 2.0 controllers.
EHCI controllers are peculiar in that they can only handle the USB 2.0
protocol. This means that they normally have one or more companion con-
trollers (i.e., ohci(4) or uhci(4)) handling USB 1.x devices. Conse-
quently each USB connector is electrically connected to two USB con-
trollers. The handling of this is totally automatic, but can be noticed
since USB 1.x and USB 2.0 devices plugged in to the same connector appear
to connect to different USB busses.
cardbus(4), ohci(4), pci(4), uhci(4), usb(4)
The ehci driver appeared in NetBSD 1.6.
The support for hubs that are connected with high speed upstream and low
or full speed downstream (i.e., for transaction translators) is limited.
NetBSD 9.2 Aug 10, 2008 NetBSD 9.2