- NetBSD Manual Pages
XENNET(4) NetBSD/xen Kernel Interfaces Manual XENNET(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
xennet -- Xen frontend paravirtualized network interface
xennet* at xenbus?
The xennet interface forms the frontend part of the paravirtualized driv-
ers used by Xen guest domains to have network connectivity.
When the host domain is NetBSD, the endpoint of the xennet interface is a
xvif(4) interface. In the XenStore, xvif and xennet are identified by
``vif'' (virtual interface) entries.
Conceptually, frontends and backends drivers are similar to two Ethernet
cards connected via a crossover cable.
xennet interfaces can pass VLAN tagged packets.
xennet%d: can't read mac address, err %d The MAC address for this inter-
face could not be read from XenStore.
xennet%d: %s is not a valid mac address The MAC address specified in the
configuration file of the newly created guest domain is invalid.
xennet%d: using event channel %d The Xen event channel (virtual inter-
rupt) ID associated to this xennet.
xennet%d: using RX copy mode The xennet and its associated endpoint use
copy mode for communication: packets are copied from one domain's memory
xennet%d: using RX flip mode The xennet and its associated endpoint use
flip mode for communication: packets are passed by remapping memory pages
bridge(4), ifmedia(4), xenbus(4), xvif(4), ifconfig(8)
The xennet driver first appeared in NetBSD 3.0.
The xennet driver was written by Manuel Bouyer <bouyer@NetBSD.org> and
Christian Limpach <firstname.lastname@example.org>.
NetBSD 9.1 November 20, 2015 NetBSD 9.1