- NetBSD Manual Pages
NEPTUNE(4) NetBSD/x68k Kernel Interfaces Manual NEPTUNE(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
neptune -- Neptune-X ISA bridge driver
neptune0 at intio0 addr 0xece000 irq 239
ne0 at neptune? addr 0x300
The Neptune-X is a Ethernet interface card initially designed by Hirofumi
Shimada, which uses popular NE2000 or its clone with its own x68k-propri-
etary bus to ISA bus bridge.
The NetBSD neptune driver takes charge of the ISA bridge part of the Nep-
tune-X. It is implemented as a more generic `bus' with its own
bus_space(9) interface, and is intended to be used with ne(4) driver.
isa(4), ne(4), x68k/intro(4), bus_space(9)
The neptune device appeared in NetBSD 1.4.
neptune itself is always detected when it is specified in the kernel con-
fig file. This is because the Neptune-X ISA bridge is transparent to
software. The attached device is detected appropriately.
NetBSD 9.1 February 17, 2017 NetBSD 9.1