- NetBSD Manual Pages
INTRO(4) NetBSD/x68k Kernel Interfaces Manual INTRO(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
intro -- introduction to x68k special files and hardware support
This section describes the special files, related driver functions, and
networking support available in the system. In this part of the manual,
the SYNOPSIS section of each configurable device gives a sample specifi-
cation for use in constructing a system description for the config(1)
program. The DIAGNOSTICS section lists messages which may appear on the
console and/or in the system error log /var/log/messages due to errors in
device operation; see syslogd(8) for more information.
This section contains both devices which may be configured into the sys-
tem and network related information. The networking support is intro-
duced in netintro(4).
X68k DEVICE SUPPORT
This section describes the hardware supported on the x68k platform.
Software support for these devices comes in two forms. A hardware device
may be supported with a character or block device driver, or it may be
used within the networking subsystem and have a network interface driver.
Block and character devices are accessed through files in the file system
of a special type; see mknod(8). Network interfaces are indirectly
accessed through the interprocess communication facilities provided by
the system; see socket(2).
A hardware device is identified to the system at configuration time and
the appropriate device or network interface driver is then compiled into
the system. When the resultant system is booted, the autoconfiguration
facilities in the system probe for the device and, if found, enable the
software support for it. If a device does not respond at autoconfigura-
tion time it is not accessible at any time afterwards. To enable a
device which did not autoconfigure, the system will have to be rebooted.
The autoconfiguration system is described in autoconf(4). A list of the
supported devices is given below.
config(1), autoconf(4), x68k/intio(4), x68k/mfp(4), x68k/neptune(4),
LIST OF DEVICES
The devices listed below are supported in this incarnation of the system.
Devices are indicated by their functional interface. Not all supported
devices are listed.
intio Internal I/O virtual device
mfp MC68901 MFP (Multi-Function Peripheral)
spc Sharp genuine MB89352 SCSI host adaptor
mha MK-HA1 Mankai-Seisakusho Mach-2 SCSI host adaptor
neptune Neptune-X Ethernet interface
fdc Built-in floppy disk controller device
fd Floppy disk device
grf Built-in frame buffer
kmem kernel virtual memory
ite x68k Internal Terminal Emulator
mem physical memory
par Centronics printer interface
com NS16450 serial interface
zs Z8530 built-in serial interface
kbd x68k Keyboard device
ms x68k mouse / trackball
bell The keyboard bell emulator
pow The power switch
vs MSM6258V built-in voice synthesizer
The x68k intro man page first appeared in NetBSD 1.3.
NetBSD 9.1 February 17, 2017 NetBSD 9.1