- NetBSD Manual Pages
WAKEONLAN(8) NetBSD System Manager's Manual WAKEONLAN(8)
Powered by man-cgi (2021-03-02).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
wakeonlan -- send Wake on LAN frames to hosts on a local Ethernet network
wakeonlan [interface] lladdr [lladdr ...]
The wakeonlan program is used to send Wake on LAN (WoL) frames over a
local Ethernet network to one or more hosts using their link layer (hard-
ware) addresses. WoL functionality is generally enabled in a machine's
BIOS and can be used to power on machines from a remote system without
having physical access to them.
interface is an Ethernet interface of the local machine and is used to
send the Wake on LAN frames over it. If there is only one Ethernet
device available that is up and running, then the interface argument can
be omitted. lladdr is the link layer address of the remote machine.
This can be specified as a hardware address or as a hostname entry in
/etc/ethers. wakeonlan accepts multiple lladdr addresses. Link layer
addresses can be determined and set using ifconfig(8).
/etc/ethers Ethernet host name data base.
The wakeonlan utility first appeared in NetBSD 6.0.
wakeonlan was written by Marc Balmer <firstname.lastname@example.org>.
NetBSD 9.1 May 13, 2018 NetBSD 9.1