- NetBSD Manual Pages
TM(4) NetBSD/vax Kernel Interfaces Manual TM(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
tm -- TM-11/TE-10 mag tape device interface
controller tm0 at uba? csr 0172520 vector tmintr tape te0 at tm0 drive 0
NOTE: This driver has not been ported from 4.4BSD yet.
The TM-11/TE-10 combination provides a standard tape drive interface as
described in vax/mtio(4). Hardware implementing this on the VAX is typi-
fied by the Emulex TC-11 controller operating with a Kennedy model 9300
tape transport, providing 800 and 1600 BPI operation at 125 IPS.
te%d: no write ring. An attempt was made to write on the tape drive when
no write ring was present; this message is written on the terminal of the
user who tried to access the tape.
te%d: not online. An attempt was made to access the tape while it was
offline; this message is written on the terminal of the user who tried to
access the tape.
te%d: can't change density in mid-tape. An attempt was made to write on
a tape at a different density than is already recorded on the tape. This
message is written on the terminal of the user who tried to switch the
te%d: hard error bn%d er=%b. A tape error occurred at block bn; the tm
error register is printed in octal with the bits symbolically decoded.
Any error is fatal on non-raw tape; when possible the driver will have
retried the operation which failed several times before reporting the
te%d: lost interrupt. A tape operation did not complete within a reason-
able time, most likely because the tape was taken off-line during rewind
or lost vacuum. The controller should, but does not, give an interrupt
in these cases. The device will be made available again after this mes-
sage, but any current open reference to the device will return an error
as the operation in progress aborts.
tar(1), vax/mt(1), vax/ht(4), vax/mt(4), vax/mtio(4), vax/ts(4),
A tm driver appeared in Version 6 AT&T UNIX.
May hang if a physical (non-data) error occurs.
NetBSD 9.1 February 17, 2017 NetBSD 9.1