- NetBSD Manual Pages
SES(4) NetBSD Kernel Interfaces Manual SES(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
ses -- SCSI Environmental Services Driver
ses* at scsibus? target ? lun ?
The ses driver provides support for all SCSI devices of the environmental
services class that are attached to the system through a supported SCSI
Host Adapter, as well as emulated support for SAF-TE (SCSI Accessible
Fault Tolerant Enclosures). The environmental services class generally
are enclosure devices that provide environmental information such as num-
ber of power supplies (and state), temperature, device slots, and so on.
A SCSI Host adapter must also be separately configured into the system
before a SCSI Environmental Services device can be configured.
The following ioctl(2) calls apply to SES devices. They are defined in
the header file <scsipi/ses.h> (q.v.).
SESIOC_GETNOBJ Used to find out how many SES objects are driven by
this particular device instance.
SESIOC_GETOBJMAP Read, from the kernel, an array of SES objects which
contains the object identifier, which sub-enclosure it
is in, and the SES type of the object.
SESIOC_GETENCSTAT Get the overall enclosure status.
SESIOC_SETENCSTAT Set the overall enclosure status.
SESIOC_GETOBJSTAT Get the status of a particular object.
SESIOC_SETOBJSTAT Set the status of a particular object.
SESIOC_GETTEXT Get the associated help text for an object (not yet
implemented). SES devices often have descriptive text
for an object which can tell you things like location
(e.g, "left power supply").
SESIOC_INIT Initialize the enclosure.
/dev/sesN The Nth ses device.
When the kernel is configured with DEBUG enabled, the first open to an
SES device will spit out overall enclosure parameters to the console.
getencstat(8), sesd(8), setencstat(8), setobjstat(8)
The ses driver was written for the SCSI subsystem by Matthew Jacob. This
is the functional equivalent of a similar driver available in Solaris,
NetBSD 9.1 May 24, 2007 NetBSD 9.1